I am having trouble logging in, what do I do?

Follow

If you are unable to log in, here are some of the common issues and resolutions:

 

"The Login or Password was incorrect. Please Try Again" Error Message

You will see this message if you have entered your login name password incorrectly, or if your profile has been made inactive.

 

  • Passwords are case sensitive, so make sure to turn off the caps lock key and verify that you have capitalized the correct letters.
  • If you are unsure if you have the correct password, click the link to email your password, type in your email address and click Send Email. If you do not have an email address, contact your training administrator for assistance.
  • Make sure that you are entering the login name exactly as it appears in your invitation email. If your login name is your email address, make sure to enter the section after the "@" symbol.
  • If you are copying and pasting your login information from the login email, make sure that you do not accidentally copy a space or extra characters from the email.
  • If you have verified that you are entering your login information correctly, or are using a login link to log in, your profile may have been set to inactive. Please contact your training administrator for assistance.

 

I forgot my password, how do I retrieve it?

The announcement email sent by your administrator will have your login information, but you can use the Forgot your Password? link directly underneath the Sign In button can be use to retrieve your password.

  • Click the Forgot your Password? link. Enter your Email address as shown below and click the Send Email button

  • You will see a success message when the email is sent:

  • If you see the message below, you may have entered your email address incorrectly, are registered without an email address or you may not be registered in the system.

 

I am immediately returned to the login page after I click the Sign In button or open a login link.

This can happen if certain settings are not enabled in your browser. Check that the following settings are enabled:

 

Comments